Hey Michael,

On Tue, 3 Sep 2013 19:30:07 -0500
Michael Moore <stuporglue at gmail.com> wrote:
> I installed Debian over the summer, replacing a Ubuntu install and
> now that I'm back at school can't get on the Wifi under Linux. It
> works fine under Windows.

> UMN and UMN Public both have a click-through hotspot page where you
> enter your un/password (for UMN) or enter a contact email address
> (UMN Public). That hotspot page DOES come up, but submitting it
> results in a spinning browser tab.

Where are you trying to connect?  I had the exact same issue you
described in Ford Hall today, though it worked fine for me in Coffman
on UMN Secure. I've always had far more troubles connecting to the UMN
networks than to other networks.  I am using the same laptop that I
used last year, a Thinkpad with an older Kubuntu install.  

Also, are you using networkmanager or wicd?  I vaguely remember having
some problems with wicd.

Oh, and one more thing... it seems UMN got eduroam wireless networks.
I haven't tried it yet, but as far as I know, you can log in with your
X500 (with @umn.edu on the end).