On Tue, 03 Sep 2013, Michael Moore said:

> The UMN Secure page uses a PEAP authentication with a certificate. I set it
> up following these instructions (
> https://wiki.umn.edu/Main/UofMSecureWirelessViaUbuntu) and it is able to
> connect successfully (IP address is assigned), but I get the same internet
> access issues.
> Any suggestions on things to try or instructions on how to debug this would
> be appreciated.
> Thank you,
> Michael Moore

Hi Michael,

I do have two colleagues here who have a lot of difficulty with recent
Ubuntu installs (13.04) on various wireless chipsets they have tried.

One of said colleagues has spent quite a lot of time troubleshooting it
and has come to believe that gnutls cares more than it probably should
about the certificate order it receives while trying to validate the
certificate chain and eventually gives up, but he doesn't have complete
evidence for this yet.

In the past couple of days, I have heard from both of them that they have
had more success and stability on wifi if they disable 802.11n and rely
instead on 802.11g.  You might give that a try...

Me personally - I run Fedora 19 on campus daily and have a good stable
wifi connection on UofM Secure using a RealTek RT2800 chipset in a little 
USB dongle ($12 Panda Wireless). My machine's built-in Broadcom BCM4311 is flaky to say the
least, but does sort of work about half the time (hence I use the dongle instead).
My current kernel is 3.10.7, but I haven't had to do anything special to
get UofM Secure connected in years (since around when that wiki page first
turned up). It should be PEAP/MSCHAPv2 as you already know.

When last I ran Debian unstable about 4-5 months ago, I didn't yet have
the RT2800 dongle and had generally a unreliable connection. It had been
some degree of flaky for me through every Fedora release on various Intel 
and Broadcom chips back as far as I can remember.  

So if you can, try to disable 802.11n and see if that helps.
Michael Berkowski
University of Minnesota Libraries
mjb at umn.edu
PGP Public Key: http://z.umn.edu/mjbpubkey

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://mailman.mn-linux.org/pipermail/tclug-list/attachments/20130903/00878710/attachment.pgp>