Update -- It turns out that the oldest kernel on the list was able to work 
in recovery mode which took me to a screen saying this:

Recovery Menu (filesystem state: read-only)

With options: resume, clean, dpkg, failsafeX, fsck, grub, network, root 
and system-summary.

Looking at system-summary it seems pretty normal to me.  The RAID seems 
intact.  So I tried "resume" next.  This got me back to the window 

Looking back, I'm wondering if my problem was that I didn't reboot the 
system after one set of updates before installing another huge batch of 
updates.  This is from back when the system was starting to behave badly 
but it was still running:

Welcome to Ubuntu 12.04 LTS (GNU/Linux 3.2.0-26-generic x86_64)
414 packages can be updated.
116 updates are security updates.
*** System restart required ***

It was asking for a reboot, but I didn't do it before updating the 
packages.  Clearly, I should have been keeping up on the updates -- I was 
used to being reminded, but when I don't see the :0 display, I don't see 
the update manager.  Now when I ssh to the box I see this:

Welcome to Ubuntu 12.04.1 LTS (GNU/Linux 3.2.0-23-generic x86_64)
9 packages can be updated.
5 updates are security updates.

So I've dropped back a few kernel versions.  What do you think I should be 
doing at this point?  I'm not sure what is wrong or how to fix it.  Maybe 
if I do the updates and reboot, I'll be back to where I want to be.

Anyone?  ;-)


On Thu, 4 Oct 2012, Mike Miller wrote:

> I installed Ubuntu 12.04 on a RAID1 array a few months ago and explained it 
> all here:
> http://permalink.gmane.org/gmane.user-groups.linux.tclug/20855
> I have been running Unity on the box but I normally attach to it via VNC 
> (with IceWM) in an SSH tunnel.  A few days ago the VNC session hung on me and 
> the Xvnc process was at 100% CPU.  I had to kill it.  (Probably a known bug, 
> but I'll skip that story for now.)  Before starting it up again, I ran 
> update-manager from the console.  I could see that there was something 
> seriously wrong with Unity -- the task bar on the side had only one item in 
> it, that was just a grayed out box, and it was unresponsive. After running 
> update-manager I rebooted.  I don't know what the exit status was for 
> update-manager because it was gone and I don't know if it did much.
> After rebooting, I have this error:
> error:invalid magic number
> error:you need to load the kernel first
> Grub will show some options for other kernels.  I have tried some, and none 
> of them will boot.  They hang with a bunch of info on the screen.
> Any ideas on how to proceed?  What tests should I be doing to find the source 
> of the problem?
> Thanks in advance.
> Mike