I installed Ubuntu 12.04 on a RAID1 array a few months ago and explained 
it all here:


I have been running Unity on the box but I normally attach to it via VNC 
(with IceWM) in an SSH tunnel.  A few days ago the VNC session hung on me 
and the Xvnc process was at 100% CPU.  I had to kill it.  (Probably a 
known bug, but I'll skip that story for now.)  Before starting it up 
again, I ran update-manager from the console.  I could see that there was 
something seriously wrong with Unity -- the task bar on the side had only 
one item in it, that was just a grayed out box, and it was unresponsive. 
After running update-manager I rebooted.  I don't know what the exit 
status was for update-manager because it was gone and I don't know if it 
did much.

After rebooting, I have this error:

error:invalid magic number
error:you need to load the kernel first

Grub will show some options for other kernels.  I have tried some, and 
none of them will boot.  They hang with a bunch of info on the screen.

Any ideas on how to proceed?  What tests should I be doing to find the 
source of the problem?

Thanks in advance.