I know that in the past when I have worked with boot-time drivers not
included in the base Redhat install I have had to recompile a kernel
with the driver as a module.

You then have to make a custom initrd image with that driver included.
The details of this are hazy but I am sure you can google for it. IIRC
all the tools you need are included with the base install. I believe
you use mkinitrd actually...

On 11/28/05, Adam <adam at askewview.net> wrote:
> Hello all,
> I'm just wondering if anyone out there has tried installing FC4 or
> Centos 4 on a machine with an AMI Raid controller. I've got a dell
> poweredge 2400 with a PERC2/dc (Rebranded AMI) RAID Controller. It
> appears that when LSI bought out AMI the removed support for the order
> AMI cards from their driver. The vanilla linux kernel from kernel.org
> has botht he old and new megaraid drivers but for some reason this
> driver is not included in the Fedora/Centos/RHEL kernels at all.
> Just looking for suggestions where to start tackling this issue.
> Thanks,
> Adam
> _______________________________________________
> TCLUG Mailing List - Minneapolis/St. Paul, Minnesota
> tclug-list at mn-linux.org
> http://mailman.mn-linux.org/mailman/listinfo/tclug-list

Loren H. Burlingame <loren at lhb.name>
GPG Key ID: 0x112DCF4F
"Irony can be pretty ironic sometimes."
   -William Shatner (a.k.a. Buck Murdock)